summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2013-02-19 22:53:23 (EST)
committer P. J. McDermott <pjm@nac.net>2013-02-19 22:53:23 (EST)
commit3675829c3fadbec2080d04404865a698b5bc3082 (patch)
tree51e3aca0ed342cde9da8ff44e39c5d796f5d9984 /configure.ac
parent35226d81ac2db45ce514f07d9be60b1dee5d88fe (diff)
downloadoverworld-rpg-3675829c3fadbec2080d04404865a698b5bc3082.zip
overworld-rpg-3675829c3fadbec2080d04404865a698b5bc3082.tar.gz
overworld-rpg-3675829c3fadbec2080d04404865a698b5bc3082.tar.bz2
Clean up some "#if 0" conditions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6b735f5..16e4ced 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,6 +62,17 @@ if test "x$enable_debug_compression" = "xyes"; then
[Define to 1 to enable debug output from tile data inflation])
fi
+AC_ARG_ENABLE([debug-render],
+ [AC_HELP_STRING([--enable-debug-render],
+ [enable debug output from map layer blits and area rendering])],
+ [enable_debug_render=yes],
+ [])
+if test "x$enable_debug_render" = "xyes"; then
+ AC_DEFINE([DEBUG_RENDER], [1],
+ [Define to 1 to enable debug output from map layer blits and
+ area rendering])
+fi
+
AC_CONFIG_FILES([Makefile])
AC_CONFIG_HEADERS([config.h])
AC_OUTPUT()