summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2013-02-19 22:44:38 (EST)
committer P. J. McDermott <pjm@nac.net>2013-02-19 22:44:38 (EST)
commit35226d81ac2db45ce514f07d9be60b1dee5d88fe (patch)
treea832d9ee8d8d733080407f23eac392525600771d /configure.ac
parent22357decdbdd612a00bcfa9291b767e6f068fd9f (diff)
downloadoverworld-rpg-35226d81ac2db45ce514f07d9be60b1dee5d88fe.zip
overworld-rpg-35226d81ac2db45ce514f07d9be60b1dee5d88fe.tar.gz
overworld-rpg-35226d81ac2db45ce514f07d9be60b1dee5d88fe.tar.bz2
Disable TMX parser debugging noise by default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4a28c1c..6b735f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,26 @@ if test "x$GCC" = "xyes"; then
fi
AC_SUBST(GCC_CFLAGS)
+AC_ARG_ENABLE([debug-tmx],
+ [AC_HELP_STRING([--enable-debug-tmx],
+ [enable debug output from TMX parser])],
+ [enable_debug_tmx=yes],
+ [])
+if test "x$enable_debug_tmx" = "xyes"; then
+ AC_DEFINE([DEBUG_TMX], [1],
+ [Define to 1 to enable debug output from TMX parser])
+fi
+
+AC_ARG_ENABLE([debug-compression],
+ [AC_HELP_STRING([--enable-debug-compression],
+ [enable debug output from tile data inflation])],
+ [enable_debug_compression=yes],
+ [])
+if test "x$enable_debug_compression" = "xyes"; then
+ AC_DEFINE([DEBUG_COMPRESSION], [1],
+ [Define to 1 to enable debug output from tile data inflation])
+fi
+
AC_CONFIG_FILES([Makefile])
AC_CONFIG_HEADERS([config.h])
AC_OUTPUT()