summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6b735f5..16e4ced 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,6 +62,17 @@ if test "x$enable_debug_compression" = "xyes"; then
[Define to 1 to enable debug output from tile data inflation])
fi
+AC_ARG_ENABLE([debug-render],
+ [AC_HELP_STRING([--enable-debug-render],
+ [enable debug output from map layer blits and area rendering])],
+ [enable_debug_render=yes],
+ [])
+if test "x$enable_debug_render" = "xyes"; then
+ AC_DEFINE([DEBUG_RENDER], [1],
+ [Define to 1 to enable debug output from map layer blits and
+ area rendering])
+fi
+
AC_CONFIG_FILES([Makefile])
AC_CONFIG_HEADERS([config.h])
AC_OUTPUT()