summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index d47aebf..a1ece4e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,10 +18,12 @@
# along with Marquee. If not, see <http://www.gnu.org/licenses/>.
if IN_GIT
-PACKAGE_VERSION_GIT = $$({ git describe --tags --dirty 2>/dev/null || \
- printf '%s-g%s%s' \
- "$$(git rev-list --count HEAD)" \
- "$$(git describe --tags --dirty --always)"; } | sed 's|^.*/||')
+PACKAGE_VERSION_GIT = $$(printf ' (%s)' \
+ "$$({ git describe --tags --dirty 2>/dev/null || \
+ printf '%s-g%s%s' \
+ "$$(git rev-list --count HEAD)" \
+ "$$(git describe --tags --dirty --always)"; \
+ } | sed 's|^.*/||')")
else
PACKAGE_VERSION_GIT =
endif