summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <pj@pehjota.net>2017-10-29 18:00:43 (EDT)
committer Patrick McDermott <pj@pehjota.net>2017-10-29 18:06:11 (EDT)
commitb58ce2a5c5811889216cc4ce6355e4243d7c9aac (patch)
tree52f743ac715a20125040346399c010bed1a1c6d2 /Makefile.am
parentf4def0d56b9b17ecda8afd5ff8db8b5539769fce (diff)
downloadmarquee-b58ce2a5c5811889216cc4ce6355e4243d7c9aac.zip
marquee-b58ce2a5c5811889216cc4ce6355e4243d7c9aac.tar.gz
marquee-b58ce2a5c5811889216cc4ce6355e4243d7c9aac.tar.bz2
Makefile.am: Add " (" and ")" to PACKAGE_VERSION_GIT
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index d47aebf..a1ece4e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,10 +18,12 @@
# along with Marquee. If not, see <http://www.gnu.org/licenses/>.
if IN_GIT
-PACKAGE_VERSION_GIT = $$({ git describe --tags --dirty 2>/dev/null || \
- printf '%s-g%s%s' \
- "$$(git rev-list --count HEAD)" \
- "$$(git describe --tags --dirty --always)"; } | sed 's|^.*/||')
+PACKAGE_VERSION_GIT = $$(printf ' (%s)' \
+ "$$({ git describe --tags --dirty 2>/dev/null || \
+ printf '%s-g%s%s' \
+ "$$(git rev-list --count HEAD)" \
+ "$$(git describe --tags --dirty --always)"; \
+ } | sed 's|^.*/||')")
else
PACKAGE_VERSION_GIT =
endif