summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5476d0d..773d449 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,9 @@
if IN_GIT
PACKAGE_VERSION_GIT = $$({ git describe --tags --dirty 2>/dev/null || \
- printf '%s' '$(PACKAGE_VERSION)'; } | sed 's|^.*/||')
+ printf '%s-g%s%s' \
+ "$$(git rev-list --count HEAD)" \
+ "$$(git describe --tags --dirty --always)"; } | sed 's|^.*/||')
else
PACKAGE_VERSION_GIT = $(PACKAGE_VERSION)
endif