summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <pj@pehjota.net>2017-10-29 17:56:02 (EDT)
committer Patrick McDermott <pj@pehjota.net>2017-10-29 17:56:02 (EDT)
commit260232dab8e6cf94df1936c89f1bfcffb574c498 (patch)
tree1eb694970e4ff05fe97a0d2aa4421e9a1f557951 /Makefile.am
parent772b990f45f05d2a77351870b5be90cf8336d722 (diff)
downloadmarquee-260232dab8e6cf94df1936c89f1bfcffb574c498.zip
marquee-260232dab8e6cf94df1936c89f1bfcffb574c498.tar.gz
marquee-260232dab8e6cf94df1936c89f1bfcffb574c498.tar.bz2
Makefile.am: Always show commit count and ID in Git ver string
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5476d0d..773d449 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,9 @@
if IN_GIT
PACKAGE_VERSION_GIT = $$({ git describe --tags --dirty 2>/dev/null || \
- printf '%s' '$(PACKAGE_VERSION)'; } | sed 's|^.*/||')
+ printf '%s-g%s%s' \
+ "$$(git rev-list --count HEAD)" \
+ "$$(git describe --tags --dirty --always)"; } | sed 's|^.*/||')
else
PACKAGE_VERSION_GIT = $(PACKAGE_VERSION)
endif