summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick McDermott <pj@pehjota.net>2017-09-15 01:11:44 (EDT)
committer Patrick McDermott <pj@pehjota.net>2017-09-15 01:11:44 (EDT)
commit69ebb03efc30cddc9d20051a22b6f09ee2571922 (patch)
tree796b433cdc50dd89ec5498de824817d9d20bd8be /configure.ac
parent4e2e41ce70e03360bbfac0dae093586824f3ad8f (diff)
downloadmarquee-69ebb03efc30cddc9d20051a22b6f09ee2571922.zip
marquee-69ebb03efc30cddc9d20051a22b6f09ee2571922.tar.gz
marquee-69ebb03efc30cddc9d20051a22b6f09ee2571922.tar.bz2
configure.ac: s/ -I/ -isystem/g in libraries' CFLAGS
This suppresses warnings in libraries' headers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d724a03..c622e95 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,10 @@ m4_foreach_w([WARN],
PKG_PROG_PKG_CONFIG()
PKG_CHECK_MODULES([GTK], [gtk+-3.0])
PKG_CHECK_MODULES([WEBKIT2GTK], [webkit2gtk-4.0])
+GTK_CFLAGS="$(printf ' %s' "${GTK_CFLAGS}" | \
+ sed 's/ -I/ -isystem/g;')"
+WEBKIT2GTK_CFLAGS="$(printf ' %s' "${WEBKIT2GTK_CFLAGS}" | \
+ sed 's/ -I/ -isystem/g;')"
AC_CONFIG_FILES([Makefile])
AC_CONFIG_HEADERS([config.h])