summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick McDermott <pj@pehjota.net>2017-09-15 00:48:50 (EDT)
committer Patrick McDermott <pj@pehjota.net>2017-09-15 00:48:50 (EDT)
commit4e2e41ce70e03360bbfac0dae093586824f3ad8f (patch)
treecaf5b3eea9e329c56bfcb384ee87669ebbe9c72e /configure.ac
downloadmarquee-4e2e41ce70e03360bbfac0dae093586824f3ad8f.zip
marquee-4e2e41ce70e03360bbfac0dae093586824f3ad8f.tar.gz
marquee-4e2e41ce70e03360bbfac0dae093586824f3ad8f.tar.bz2
Add build system and related files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac58
1 files changed, 58 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..d724a03
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,58 @@
+# Process this file with autoconf to produce a configure script.
+#
+# Copyright (C) 2017 Patrick McDermott
+#
+# This file is part of Marquee.
+
+# Marquee is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# Marquee is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Marquee. If not, see <http://www.gnu.org/licenses/>.
+
+AC_INIT([Marquee], [0.1.0],
+ [mailto:pj@pehjota.net], [marquee])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR([src/main.c])
+
+AM_INIT_AUTOMAKE([gnu check-news dist-bzip2 dist-xz subdir-objects])
+AM_SILENT_RULES([yes])
+
+AM_CONDITIONAL([IN_GIT],
+ [test -d "${srcdir}/.git" && command -v git >/dev/null 2>&1])
+
+AC_PROG_CC()
+AM_PROG_CC_C_O()
+
+# Consider also:
+# * -Wchkp
+# * -Wformat=2
+# * -Wnull-dereference
+# * -Winit-self
+# * -Wmissing-include-dirs
+# * etc.
+# Cf. <https://gcc.gnu.org/onlinedocs/gcc/Warning-Options.html> and
+# <http://git.pehjota.net/overworld-rpg/overworld-rpg.git/tree/configure.ac#n60>
+m4_foreach_w([WARN],
+ [
+ -Wpedantic -Wall -Wextra
+ ], [
+ AX_CHECK_COMPILE_FLAG([WARN], [CFLAGS="${CFLAGS} WARN"], [], [])
+ ]
+)
+
+PKG_PROG_PKG_CONFIG()
+PKG_CHECK_MODULES([GTK], [gtk+-3.0])
+PKG_CHECK_MODULES([WEBKIT2GTK], [webkit2gtk-4.0])
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_HEADERS([config.h])
+AC_OUTPUT()