summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 12 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 849a5d6..952c429 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,20 +13,26 @@ dnl GNU General Public License for more details.
dnl
dnl You should have received a copy of the GNU General Public License
dnl along with this program; if not, write to the Free Software
-dnl Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+dnl Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
dnl
dnl ------------------------
dnl The following line is the MASTER SOURCE for the version number
-AC_INIT(Xcftools,0.7.1,henning@makholm.net,xcftools)
+AC_INIT(Xcftools,0.9,henning@makholm.net,xcftools)
AC_COPYRIGHT(General copyright notice for AC_PACKAGE_NAME:
[@COPYRIGHT@ Henning Makholm]
)
AC_CONFIG_SRCDIR(xcfinfo.c)
-AC_PROG_MAKE_SET
AC_PROG_INSTALL
AC_ARG_PROGRAM
+AC_ARG_ENABLE(precomputed-scaletable,
+ AC_HELP_STRING([--enable-precomputed-scaletable],
+ [Use precomputed multiplication table (adds 64 KB per binary)]),
+ [AC_DEFINE(PRECOMPUTED_SCALETABLE,1,
+ [Define to use a precomputed multiplication table (adds 64 KB per binary)]
+ )])
+
AC_PROG_CC
case $GCC::$CFLAGS in yes::*-Wall* ) ;;
yes::*) CFLAGS="$CFLAGS -Wall" ;;
@@ -46,10 +52,11 @@ AC_CHECK_HEADERS(inttypes.h netinet/in.h arpa/inet.h getopt.h)
AC_CHECK_FUNCS(getopt_long strcasecmp)
AC_FUNC_MMAP
+dnl AM_GNU_GETTEXT(external)
AM_ICONV
AC_CHECK_PROG(PERL,perl,perl)
-
+
AC_CONFIG_HEADERS(config.h:config.hin)
-AC_CONFIG_FILES(Makefile)
+AC_CONFIG_FILES(Makefile:Makefile.in)
AC_OUTPUT