summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHenning Makholm <henning@makholm.net>2006-01-27 18:00:00 (EST)
committer Julien Jorge <julien.jorge@stuff-o-matic.com>2013-01-10 16:00:40 (EST)
commit7b7cd6da61b1fcc0f2a3ecce2cb9e6c42782c717 (patch)
tree98d2772f50aaddb02ac94492d2b8b151aa3e9465 /configure.ac
downloadxcftools-7b7cd6da61b1fcc0f2a3ecce2cb9e6c42782c717.zip
xcftools-7b7cd6da61b1fcc0f2a3ecce2cb9e6c42782c717.tar.gz
xcftools-7b7cd6da61b1fcc0f2a3ecce2cb9e6c42782c717.tar.bz2
Import of release 0.7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac56
1 files changed, 56 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..c337371
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,56 @@
+dnl Configure script for xcftools
+dnl
+dnl Copyright (C) 2006 Henning Makholm
+dnl
+dnl This program is free software; you can redistribute it and/or modify
+dnl it under the terms of version 2 of the GNU General Public License as
+dnl published by the Free Software Foundation.
+dnl
+dnl This program is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+dnl GNU General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU General Public License
+dnl along with this program; if not, write to the Free Software
+dnl Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+dnl
+dnl ------------------------
+dnl The following line is the MASTER SOURCE for the version number
+AC_INIT(Xcftools,0.7,henning@makholm.net,xcftools)
+AC_COPYRIGHT(General copyright notice for AC_PACKAGE_NAME:
+ [@COPYRIGHT@ Henning Makholm]
+)
+AC_REVISION($Id: configure.ac,v 1.6 2006/01/28 21:02:16 makholm Exp $)
+AC_CONFIG_SRCDIR(xcfinfo.c)
+
+AC_PROG_MAKE_SET
+AC_PROG_INSTALL
+AC_ARG_PROGRAM
+
+AC_PROG_CC
+case $GCC::$CFLAGS in yes::*-Wall* ) ;;
+ yes::*) CFLAGS="$CFLAGS -Wall" ;;
+esac
+case $GCC::$CFLAGS in *-g* | *omit-frame-pointer* ) ;;
+ yes::*) CFLAGS="$CFLAGS -fomit-frame-pointer" ;;
+esac
+AC_C_INLINE
+
+AC_C_BIGENDIAN
+AC_CANONICAL_HOST
+case $host_cpu in i?86 | x86_64 | powerpc)
+ AC_DEFINE(CAN_DO_UNALIGNED_WORDS,1,
+ [Define for CPUs that can read unaligned words without traps or faults])
+esac
+AC_CHECK_HEADERS(inttypes.h netinet/in.h arpa/inet.h getopt.h)
+
+AC_CHECK_FUNCS(getopt_long strcasecmp)
+AC_FUNC_MMAP
+AM_ICONV
+
+AC_CHECK_PROG(PERL,perl,perl)
+
+AC_CONFIG_HEADERS(config.h:config.hin)
+AC_CONFIG_FILES(Makefile)
+AC_OUTPUT