summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3c6af94..b221f7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,14 +84,17 @@ if test "x${address_sanitization}" = 'xyes'; then
fi
AC_CHECK_LIB([curses], [initscr],
- [timeteller_LDADD="-lcurses ${timeteller_LDADD}"],
+ [CURSES_LIBS=-lcurses],
[AC_MSG_ERROR([No library -lcurses found])])
+AC_SUBST([CURSES_LIBS])
AC_CHECK_LIB([flite], [flite_init],
- [timeteller_LDADD="-lflite ${timeteller_LDADD}"],
+ [FLITE_LIBS=-lflite],
[AC_MSG_ERROR([No library -lflite found])])
+AC_SUBST([FLITE_LIBS])
AC_CHECK_LIB([flite_cmu_us_slt], [register_cmu_us_slt],
- [timeteller_LDADD="-lflite_cmu_us_slt ${timeteller_LDADD}"],
+ [FLITE_CMU_US_SLT_LIBS=-lflite_cmu_us_slt],
[AC_MSG_ERROR([No library -lflite_cmu_us_slt found])])
+AC_SUBST([FLITE_CMU_US_SLT_LIBS])
AC_CONFIG_FILES([Makefile])
AC_CONFIG_HEADERS([config.h])