summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 3 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 2fac9ae..8767989 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# Process this file with autoconf to produce a configure script.
+dnl Process this file with autoconf to produce a configure script.
#
# Copyright (C) 2013 Patrick "P. J." McDermott
#
@@ -68,7 +68,6 @@ AC_ARG_WITH(
;;
*)
XCF2PNG="${withval}"
- AC_SUBST([XCF2PNG])
embedded_xcf2png=false
;;
esac
@@ -78,15 +77,11 @@ AC_ARG_WITH(
]
)
if ${embedded_xcf2png}; then
- AS_MKDIR_P([3rdparty/xcftools])
+ AC_CONFIG_SUBDIRS([3rdparty/xcftools])
XCF2PNG='3rdparty/xcftools/xcf2png$(EXEEXT)'
- abs_srcdir="$(cd "${srcdir}" && pwd)"
- (
- cd 3rdparty/xcftools
- "${SHELL}" "${abs_srcdir}/3rdparty/xcftools/configure"
- )
fi
AM_CONDITIONAL([EMBEDDED_XCF2PNG], [${embedded_xcf2png}])
+AC_SUBST([XCF2PNG])
if test "x$GCC" = "xyes"; then
GCC_CFLAGS="-pedantic -Wall -Wextra -Werror"