summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2013-02-22 21:32:50 (EST)
committer P. J. McDermott <pjm@nac.net>2013-02-22 22:11:03 (EST)
commit708db30ba67192e37462a849efe59a437b2d8319 (patch)
treef6d7931ac16f15af4bfbf940329aaa7ccef41d8a /configure.ac
parentaf991978ce1fade0f843a8ce97863adf1f95c260 (diff)
downloadoverworld-rpg-708db30ba67192e37462a849efe59a437b2d8319.zip
overworld-rpg-708db30ba67192e37462a849efe59a437b2d8319.tar.gz
overworld-rpg-708db30ba67192e37462a849efe59a437b2d8319.tar.bz2
Optionally list palette colors of loaded images.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2ed524a..f0921fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,7 +58,7 @@ AC_ARG_ENABLE([debug-tmx],
[])
if test "x$enable_debug_tmx" = "xyes"; then
AC_DEFINE([DEBUG_TMX], [1],
- [Define to 1 to enable debug output from TMX parser])
+ [Define to 1 to enable debug output from TMX parser.])
fi
AC_ARG_ENABLE([debug-compression],
@@ -68,7 +68,7 @@ AC_ARG_ENABLE([debug-compression],
[])
if test "x$enable_debug_compression" = "xyes"; then
AC_DEFINE([DEBUG_COMPRESSION], [1],
- [Define to 1 to enable debug output from tile data inflation])
+ [Define to 1 to enable debug output from tile data inflation.])
fi
AC_ARG_ENABLE([debug-render],
@@ -79,7 +79,18 @@ AC_ARG_ENABLE([debug-render],
if test "x$enable_debug_render" = "xyes"; then
AC_DEFINE([DEBUG_RENDER], [1],
[Define to 1 to enable debug output from map layer blits and
- area rendering])
+ area rendering.])
+fi
+
+AC_ARG_ENABLE([debug-palettes],
+ [AC_HELP_STRING([--enable-debug-palettes],
+ [enable debug output with surface palette colors listings])],
+ [enable_debug_palettes=yes],
+ [])
+if test "x$enable_debug_palettes" = "xyes"; then
+ AC_DEFINE([DEBUG_PALETTES], [1],
+ [Define to 1 to enable debug output with surface palette colors
+ listings.])
fi
AC_CONFIG_FILES([Makefile])