summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2013-02-15 18:18:07 (EST)
committer P. J. McDermott <pjm@nac.net>2013-02-15 18:18:07 (EST)
commit63349a6230304a7f1aa34a4c96e4873f86bf39c5 (patch)
tree6bc693e4da8a8f66e3c874ef5e7f8ce13dec6626 /Makefile.am
parentae21d4dd860ed312d9dccec62dd0ec822d736f86 (diff)
downloadoverworld-rpg-63349a6230304a7f1aa34a4c96e4873f86bf39c5.zip
overworld-rpg-63349a6230304a7f1aa34a4c96e4873f86bf39c5.tar.gz
overworld-rpg-63349a6230304a7f1aa34a4c96e4873f86bf39c5.tar.bz2
Split Makefile.am in recursively-included files.
The modular maintenance benefits of recursive make without any of the problems of recursive make!
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index b7a392e..d2a7843 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,8 @@
bin_PROGRAMS = sdlex
-sdlex_SOURCES = src/main.c src/init.c src/logging.c \
- src/base64.c src/compression.c \
- src/tmx.c src/resources/resource.c src/resources/image.c
+include $(top_srcdir)/src/Makefile.am
+
+sdlex_SOURCES = $(src_SOURCES)
sdlex_CFLAGS = $(GCC_CFLAGS) \
$(SDL_CFLAGS) \
@@ -14,4 +14,3 @@ sdlex_LDADD = $(SDL_LIBS) \
$(SDL_IMAGE_LIBS) \
$(ZLIB_LIBS) \
$(EXPAT_LIBS)
-