summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2013-11-02 21:55:30 (EDT)
committer P. J. McDermott <pjm@nac.net>2013-11-02 21:55:30 (EDT)
commit4f80dbf8da190d363823373e739ea51960a64832 (patch)
treefe655202f4caa2570d334978320df9ceb3ddafac /Makefile.am
parentee9aba53fe7a5b66f5298ee7c0ab2add78a2efc3 (diff)
downloadoverworld-rpg-4f80dbf8da190d363823373e739ea51960a64832.zip
overworld-rpg-4f80dbf8da190d363823373e739ea51960a64832.tar.gz
overworld-rpg-4f80dbf8da190d363823373e739ea51960a64832.tar.bz2
Centralize *dir stuff into Makefile.am.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b3b36ff..2dfb0d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,6 @@
+mapsdir = $(pkgdatadir)/maps
+tilesetsdir = $(pkgdatadir)/tilesets
+
bin_PROGRAMS = sdlex
sdlex_SOURCES =
@@ -6,7 +9,9 @@ sdlex_CPPFLAGS = \
$(SDL_CFLAGS) \
$(SDL_IMAGE_CFLAGS) \
$(ZLIB_CFLAGS) \
- $(EXPAT_CFLAGS)
+ $(EXPAT_CFLAGS) \
+ -DMAPSDIR=\"$(mapsdir)\" \
+ -DTILESETSDIR=\"$(tilesetsdir)\"
sdlex_CFLAGS = \
$(GCC_CFLAGS)