summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2023-02-24 08:52:32 (EST)
committer P. J. McDermott <pj@pehjota.net>2023-02-24 08:52:32 (EST)
commit0b360f0c7de63ddb9bb20d2fead9e077d9fef735 (patch)
treea9c4e232ec16948407df94b94d8bac968de92330 /Makefile.am
parent50e8259639936c867c486917aba8d9f748a35d2c (diff)
downloadoverworld-rpg-0b360f0c7de63ddb9bb20d2fead9e077d9fef735.zip
overworld-rpg-0b360f0c7de63ddb9bb20d2fead9e077d9fef735.tar.gz
overworld-rpg-0b360f0c7de63ddb9bb20d2fead9e077d9fef735.tar.bz2
build: Use ASAN and GCC warnings from Gnulib
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2465627..e78fe46 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,7 +34,8 @@ boukengine_CPPFLAGS = \
-DTILESETSDIR=\"$(tilesetsdir)\"
boukengine_CFLAGS = \
- $(GCC_CFLAGS)
+ $(WARN_CFLAGS) \
+ $(ASAN_CFLAGS)
boukengine_LDADD = \
-lm \