summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick McDermott <pj@pehjota.net>2017-10-25 12:36:41 (EDT)
committer Patrick McDermott <pj@pehjota.net>2017-10-25 12:36:41 (EDT)
commitec249526ef406db942067c274415d17fb923c2cc (patch)
tree1581e4e3dd5f324b5c689764a14d3e8e03753867 /configure.ac
parentc64472f47e5434caddb247ca9e7500111b82f7dc (diff)
downloadmarquee-ec249526ef406db942067c274415d17fb923c2cc.zip
marquee-ec249526ef406db942067c274415d17fb923c2cc.tar.gz
marquee-ec249526ef406db942067c274415d17fb923c2cc.tar.bz2
MqTree: Fix width of pointers in debugging output
And modify configure.ac to search for logl() and add -lm to LIBS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9d82351..e6ff630 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,6 +69,8 @@ AC_ARG_ENABLE(
[enable_debug=no])
if test "x${enable_debug}" = 'xyes'; then
+ AC_SEARCH_LIBS([logl], [m], [],
+ [AC_MSG_ERROR([unable to find the logl() function])])
AC_DEFINE([MQ_TREE_DEBUG], [1], [Define to 1 to enable tree debugging.])
else
AC_DEFINE([MQ_TREE_DEBUG], [0], [Define to 1 to enable tree debugging.])