summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick McDermott <pj@pehjota.net>2017-10-23 19:46:11 (EDT)
committer Patrick McDermott <pj@pehjota.net>2017-10-23 19:46:11 (EDT)
commitcb019a4ed1614349f87206a814dbea3c39b72303 (patch)
treefa2684d28e1c0b626a30b8e4f447d19f8bc6942a /configure.ac
parent8b377cf9ce039dbfdfdd128abaa0c3ed93dff941 (diff)
downloadmarquee-cb019a4ed1614349f87206a814dbea3c39b72303.zip
marquee-cb019a4ed1614349f87206a814dbea3c39b72303.tar.gz
marquee-cb019a4ed1614349f87206a814dbea3c39b72303.tar.bz2
configure.ac: Add --enable-debug arg that sets MQ_TREE_DEBUG
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5468432..9d82351 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,6 +62,18 @@ GTK_CFLAGS="$(printf ' %s' "${GTK_CFLAGS}" | \
WEBKIT2GTK_CFLAGS="$(printf ' %s' "${WEBKIT2GTK_CFLAGS}" | \
sed 's/ -I/ -isystem/g;')"
+AC_ARG_ENABLE(
+ [debug],
+ [AS_HELP_STRING([--enable-debug], [enable debugging])],
+ ,
+ [enable_debug=no])
+
+if test "x${enable_debug}" = 'xyes'; then
+ AC_DEFINE([MQ_TREE_DEBUG], [1], [Define to 1 to enable tree debugging.])
+else
+ AC_DEFINE([MQ_TREE_DEBUG], [0], [Define to 1 to enable tree debugging.])
+fi
+
AC_CONFIG_FILES([Makefile])
AC_CONFIG_HEADERS([config.h])
AC_OUTPUT()