summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick McDermott <pj@pehjota.net>2017-09-15 02:55:27 (EDT)
committer Patrick McDermott <pj@pehjota.net>2017-09-15 02:55:27 (EDT)
commit9044cf4c25d63873c50218cc4c5b4c19a057c545 (patch)
tree0bff174a9e45a647380bd803aa7cdeb5a65f7280 /configure.ac
parent5e6822edb1d222ff97d440ea6743890a6e4c2514 (diff)
downloadmarquee-9044cf4c25d63873c50218cc4c5b4c19a057c545.zip
marquee-9044cf4c25d63873c50218cc4c5b4c19a057c545.tar.gz
marquee-9044cf4c25d63873c50218cc4c5b4c19a057c545.tar.bz2
configure.ac: Compile with "-std=c99"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c622e95..87d3d43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,8 @@ AM_CONDITIONAL([IN_GIT],
AC_PROG_CC()
AM_PROG_CC_C_O()
+AX_CHECK_COMPILE_FLAG([-std=c99], [CFLAGS="${CFLAGS} -std=c99"], [], [])
+
# Consider also:
# * -Wchkp
# * -Wformat=2