summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick McDermott <pj@pehjota.net>2017-10-27 08:14:54 (EDT)
committer Patrick McDermott <pj@pehjota.net>2017-10-27 08:14:54 (EDT)
commit4c8e42cd6408a46d084a0a07cb6e7ae74905c78a (patch)
tree2027dd0d9d39536d65b0bed6b31be25b6cb59390 /configure.ac
parent30ab3f72a0c6591182a58c1bf59ee917f0136aba (diff)
downloadmarquee-4c8e42cd6408a46d084a0a07cb6e7ae74905c78a.zip
marquee-4c8e42cd6408a46d084a0a07cb6e7ae74905c78a.tar.gz
marquee-4c8e42cd6408a46d084a0a07cb6e7ae74905c78a.tar.bz2
configure.ac: Add --enable-in-place arg and RUN_IN_PLACE macro
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e6ff630..2b4ba54 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,7 +67,6 @@ AC_ARG_ENABLE(
[AS_HELP_STRING([--enable-debug], [enable debugging])],
,
[enable_debug=no])
-
if test "x${enable_debug}" = 'xyes'; then
AC_SEARCH_LIBS([logl], [m], [],
[AC_MSG_ERROR([unable to find the logl() function])])
@@ -76,6 +75,20 @@ else
AC_DEFINE([MQ_TREE_DEBUG], [0], [Define to 1 to enable tree debugging.])
fi
+AC_ARG_ENABLE(
+ [in-place],
+ [AS_HELP_STRING([--enable-in-place],
+ [run executable in place from build directory])],
+ ,
+ [enable_in_place=no])
+if test "x${enable_in_place}" = 'xyes'; then
+ AC_DEFINE([RUN_IN_PLACE], [1],
+ [Define to 1 to run executable in place from build directory.])
+else
+ AC_DEFINE([RUN_IN_PLACE], [0],
+ [Define to 1 to run executable in place from build directory.])
+fi
+
AC_CONFIG_FILES([Makefile])
AC_CONFIG_HEADERS([config.h])
AC_OUTPUT()