summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick McDermott <pj@pehjota.net>2017-11-01 14:55:12 (EDT)
committer Patrick McDermott <pj@pehjota.net>2017-11-01 14:55:12 (EDT)
commit499e5564a79faece95f341e0c185543dc19de8a6 (patch)
tree56fd0186ff712d48fbeec16456724cb174980014 /configure.ac
parent812bdd5f2a1b1a5afa72255cbdaf94d10fd090aa (diff)
downloadmarquee-499e5564a79faece95f341e0c185543dc19de8a6.zip
marquee-499e5564a79faece95f341e0c185543dc19de8a6.tar.gz
marquee-499e5564a79faece95f341e0c185543dc19de8a6.tar.bz2
configure.ac: Use AX_CFLAGS_WARN_ALL() instead of -Wall check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 67cccf2..f3a09f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,13 +46,9 @@ AX_CHECK_COMPILE_FLAG([-std=c11], [CFLAGS="${CFLAGS} -std=c11"], [
# * etc.
# Cf. <https://gcc.gnu.org/onlinedocs/gcc/Warning-Options.html> and
# <http://git.pehjota.net/overworld-rpg/overworld-rpg.git/tree/configure.ac#n60>
-m4_foreach_w([WARN],
- [
- -Wpedantic -Wall -Wextra
- ], [
- AX_CHECK_COMPILE_FLAG([WARN], [CFLAGS="${CFLAGS} WARN"], [], [])
- ]
-)
+AX_CFLAGS_WARN_ALL() dnl Adds -Wall or equivalent
+AX_CHECK_COMPILE_FLAG([-Wpedantic], [AX_APPEND_FLAG([-Wpedantic])])
+AX_CHECK_COMPILE_FLAG([-Wextra], [AX_APPEND_FLAG([-Wextra])])
AX_CHECK_COMPILE_FLAG([-fdiagnostics-color=auto],
[CFLAGS="${CFLAGS} -fdiagnostics-color=auto"], [], [])