summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <pj@pehjota.net>2017-09-15 00:48:50 (EDT)
committer Patrick McDermott <pj@pehjota.net>2017-09-15 00:48:50 (EDT)
commit4e2e41ce70e03360bbfac0dae093586824f3ad8f (patch)
treecaf5b3eea9e329c56bfcb384ee87669ebbe9c72e /Makefile.am
downloadmarquee-4e2e41ce70e03360bbfac0dae093586824f3ad8f.zip
marquee-4e2e41ce70e03360bbfac0dae093586824f3ad8f.tar.gz
marquee-4e2e41ce70e03360bbfac0dae093586824f3ad8f.tar.bz2
Add build system and related files
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..90cb803
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,46 @@
+# Process this file with automake to produce an input makefile.
+#
+# Copyright (C) 2017 Patrick McDermott
+#
+# This file is part of Marquee.
+
+# Marquee is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# Marquee is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Marquee. If not, see <http://www.gnu.org/licenses/>.
+
+if IN_GIT
+PACKAGE_VERSION_GIT = $$(git describe --tags --dirty | sed 's|^.*/||')
+else
+PACKAGE_VERSION_GIT = $(PACKAGE_VERSION)
+endif
+
+# PACKAGE_STRING is used in the test suite output and log.
+# PACKAGE_VERSION can't be overridden. Automake ignores it in the IN_GIT
+# conditional (and throws a warning), and setting it to $(PACKAGE_VERSION_GIT)
+# outside the conditional causes PACKAGE_VERSION_GIT to reference itself.
+# VERSION is not set here because it is used by:
+# * Automake's distdir macro
+# * Automake's distdir target (which checks for $(VERSION) in NEWS)
+# * Our release target
+PACKAGE_STRING = $(PACKAGE_NAME) $(PACKAGE_VERSION_GIT)
+
+bin_PROGRAMS = marquee
+
+marquee_SOURCES =
+marquee_CPPFLAGS = \
+ $(GTK_CFLAGS) \
+ $(WEBKIT2GTK_CFLAGS)
+marquee_LDADD = \
+ $(GTK_LIBS) \
+ $(WEBKIT2GTK_LIBS)
+
+include $(top_srcdir)/src/local.mk