summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4c0010a..08de33a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,12 @@ firman_SOURCES =
# Hack to work around Automake's lack of support for linking programs in other
# languages.
firman_LDADD = config.sh $(firman_SOURCES)
-firman_LINK = '$(srcdir)/tools/shld.sh' -I '$(SH)' -o $@
+firman_LINK = \
+ set -e; \
+ for f in $(firman_LDADD); do \
+ $(SH) -n "$${f}"; \
+ done; \
+ '$(srcdir)/tools/shld.sh' -I '$(SH)' -o $@
EXTRA_DIST = \
autogen.sh