summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2015-10-28 12:49:11 (EDT)
committer P. J. McDermott <pj@pehjota.net>2015-10-28 12:49:11 (EDT)
commitd0a313900c7b47eea29d91206dbde9e8e43ef9fe (patch)
tree2da15bbc87b919136898f9f0db56debc9e470c8c /Makefile.am
parented4d7b78d105b4f6c1e96189953f89b15f5aaacf (diff)
downloadfirman.sh-d0a313900c7b47eea29d91206dbde9e8e43ef9fe.zip
firman.sh-d0a313900c7b47eea29d91206dbde9e8e43ef9fe.tar.gz
firman.sh-d0a313900c7b47eea29d91206dbde9e8e43ef9fe.tar.bz2
Makefile.am: Check syntax of each source file
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4c0010a..08de33a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,12 @@ firman_SOURCES =
# Hack to work around Automake's lack of support for linking programs in other
# languages.
firman_LDADD = config.sh $(firman_SOURCES)
-firman_LINK = '$(srcdir)/tools/shld.sh' -I '$(SH)' -o $@
+firman_LINK = \
+ set -e; \
+ for f in $(firman_LDADD); do \
+ $(SH) -n "$${f}"; \
+ done; \
+ '$(srcdir)/tools/shld.sh' -I '$(SH)' -o $@
EXTRA_DIST = \
autogen.sh