summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2015-10-27 00:10:33 (EDT)
committer P. J. McDermott <pj@pehjota.net>2015-10-27 00:10:33 (EDT)
commitfc46142f24c6fe8b28cf7699e6d22da9f5c55cd1 (patch)
treec8cdbe8e5cd8c781e57e4df91f4a2ff8954ea14f /configure.ac
parent1302fa5666a62078ebdf67ebbb1635097fc38c56 (diff)
downloadfirman.sh-fc46142f24c6fe8b28cf7699e6d22da9f5c55cd1.zip
firman.sh-fc46142f24c6fe8b28cf7699e6d22da9f5c55cd1.tar.gz
firman.sh-fc46142f24c6fe8b28cf7699e6d22da9f5c55cd1.tar.bz2
configure.ac: New file
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac129
1 files changed, 129 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..57fd6dc
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,129 @@
+# Process this file with autoconf to produce a configure script.
+#
+# Copyright (C) 2013, 2015 Patrick "P. J." McDermott
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+AC_INIT([Firmware Manager], [0.1.0], [mailto:pj@pehjota.net], [firman.sh], [])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_SRCDIR([src/main.sh])
+
+AM_INIT_AUTOMAKE([gnu check-news dist-bzip2 dist-xz subdir-objects])
+AM_SILENT_RULES([yes])
+
+AC_ARG_WITH(
+ [sh],
+ [AS_HELP_STRING([--with-sh], [POSIX-conformant shell with `local'])],
+ dnl This `dnl' is needed to workaround Vim syntax highlighting.
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR([--with-sh requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([sh is required])
+ ;;
+ *)
+ SH="${withval}"
+ AC_SUBST([SH])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([SH], [sh])
+ if test -z "${SH}"; then
+ AC_MSG_ERROR([sh not found])
+ fi
+ ]
+)
+
+AC_ARG_WITH(
+ [flashrom],
+ [AS_HELP_STRING([--with-flashrom=PATH], [path to flashrom utility])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-flashrom requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([flashrom is required])
+ ;;
+ *)
+ FLASHROM="${withval}"
+ AC_SUBST([FLASHROM])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([FLASHROM], [flashrom])
+ if test -z "${FLASHROM}"; then
+ AC_MSG_ERROR([flashrom not found])
+ fi
+ ]
+)
+AC_ARG_WITH(
+ [wget],
+ [AS_HELP_STRING([--with-wget=PATH], [path to wget utility])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-wget requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([wget is required])
+ ;;
+ *)
+ WGET="${withval}"
+ AC_SUBST([WGET])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([WGET], [wget])
+ if test -z "${WGET}"; then
+ AC_MSG_ERROR([wget not found])
+ fi
+ ]
+)
+AC_ARG_WITH(
+ [ich9gen],
+ [AS_HELP_STRING([--with-ich9gen=PATH], [path to ich9gen utility])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-ich9gen requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([ich9gen is required])
+ ;;
+ *)
+ ICH9GEN="${withval}"
+ AC_SUBST([ICH9GEN])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([ICH9GEN], [ich9gen])
+ if test -z "${ICH9GEN}"; then
+ AC_MSG_ERROR([ich9gen not found])
+ fi
+ ]
+)
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([config.sh])
+AC_OUTPUT()