summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2015-10-28 12:15:23 (EDT)
committer P. J. McDermott <pj@pehjota.net>2015-10-28 12:15:23 (EDT)
commit260e3a1ea414ecf8c9d9b26295927413ede9efcd (patch)
treed47b118694e686ea47a01f864f804e6e0547a4cc /configure.ac
parent839d6808e28d8ad39f95c1820ceca1165dd08e72 (diff)
downloadfirman.sh-260e3a1ea414ecf8c9d9b26295927413ede9efcd.zip
firman.sh-260e3a1ea414ecf8c9d9b26295927413ede9efcd.tar.gz
firman.sh-260e3a1ea414ecf8c9d9b26295927413ede9efcd.tar.bz2
configure.ac: Find sha512sum utility
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 57fd6dc..b76752f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,6 +99,31 @@ AC_ARG_WITH(
]
)
AC_ARG_WITH(
+ [sha512sum],
+ [AS_HELP_STRING([--with-sha512sum=PATH], [path to sha512sum utility])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-sha512sum requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([sha512sum is required])
+ ;;
+ *)
+ SHA512SUM="${withval}"
+ AC_SUBST([SHA512SUM])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([SHA512SUM], [sha512sum])
+ if test -z "${SHA512SUM}"; then
+ AC_MSG_ERROR([sha512sum not found])
+ fi
+ ]
+)
+AC_ARG_WITH(
[ich9gen],
[AS_HELP_STRING([--with-ich9gen=PATH], [path to ich9gen utility])],
[