summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2015-10-27 01:06:26 (EDT)
committer P. J. McDermott <pj@pehjota.net>2015-10-27 01:06:26 (EDT)
commite12bc2d8c20c47e58cc920ffcbbf8b58133a1022 (patch)
treed3220d226b1a5e2152a41a348dd8bab894faab89 /Makefile.am
parentb61374a59c4b6bec893a3902593c161c6b65ee40 (diff)
downloadfirman.sh-e12bc2d8c20c47e58cc920ffcbbf8b58133a1022.zip
firman.sh-e12bc2d8c20c47e58cc920ffcbbf8b58133a1022.tar.gz
firman.sh-e12bc2d8c20c47e58cc920ffcbbf8b58133a1022.tar.bz2
Makefile.am: New file
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am97
1 files changed, 97 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..1085825
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,97 @@
+# Process this file with automake to produce an input makefile.
+#
+# Copyright (C) 2013, 2014 Patrick "P. J." McDermott
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+SUFFIXES = .sh
+
+sbin_PROGRAMS = firman
+
+firman_SOURCES =
+# Hack to work around Automake's lack of support for linking programs in other
+# languages.
+firman_LDADD = $(firman_SOURCES)
+firman_LINK = '$(srcdir)/tools/shld.sh' -o $@
+
+EXTRA_DIST = \
+ autogen.sh
+
+todo_script = \
+ /^[0-9]* .[ \t]*\#[ \t]*TODO/,/^[0-9]* \.[ \t]*[^ \t\#]/{ \
+ /^[0-9]* \.[ \t]*\#/p; \
+ }; \
+ /^[0-9]* .[ \t]*\#[ \t]*FIXME/,/^[0-9]* \.[ \t]*[^ \t\#]/{ \
+ /^[0-9]* \.[ \t]*\#/p; \
+ }; \
+ /^[0-9]* .[ \t]*\#[ \t]*XXX/,/^[0-9]* \.[ \t]*[^ \t\#]/{ \
+ /^[0-9]* \.[ \t]*\#/p; \
+ };
+todo:
+ @set -e; \
+ printf '\n'; \
+ printf 'Code comments:\n'; \
+ printf '==============\n\n'; \
+ for f in $(firman_SOURCES); do \
+ printed=false; \
+ sed '=' "$(top_srcdir)/$${f}" | sed 'N; s/\n/ ./' | sed -n \
+ '$(todo_script)' | while read -r lineno line; do \
+ if ! $${printed}; then \
+ printf '%s:\n' "$${f}"; \
+ printed=true; \
+ fi; \
+ printf ' %6d %s\n' $${lineno} "$${line#.}"; \
+ done; \
+ done; \
+ printf '\n'; \
+ if [ -f '$(top_srcdir)/TODO' ]; then \
+ printf 'TODO file:\n'; \
+ printf '==========\n\n'; \
+ cat '$(top_srcdir)/TODO'; \
+ printf '\n'; \
+ fi
+
+really-clean: distclean
+ rm -Rf $(srcdir)/aclocal.m4 $(srcdir)/autom4te.cache/ \
+ $(srcdir)/configure \
+ $(srcdir)/build-aux/ $(srcdir)/INSTALL $(srcdir)/Makefile.in \
+ $(srcdir)/ChangeLog
+
+dist-hook:
+ if [ -d '$(srcdir)/.git' ]; then \
+ printf 'Generated file. Do not edit.\n\n' \
+ >'$(distdir)/ChangeLog~'; \
+ GIT_DIR='$(srcdir)/.git' git log --stat --color=never \
+ >>'$(distdir)/ChangeLog~'; \
+ mv '$(distdir)/ChangeLog~' '$(distdir)/ChangeLog'; \
+ fi
+
+release:
+ sed "s/^Released: ????-??-??\$$/Released: $$(date '+%Y-%m-%d')/" \
+ '$(srcdir)/NEWS' >'$(srcdir)/NEWS~'
+ mv '$(srcdir)/NEWS~' '$(srcdir)/NEWS'
+ $(MAKE) distcheck
+ set -e; \
+ export GIT_DIR='$(srcdir)/.git'; \
+ export GIT_WORK_TREE='$(srcdir)'; \
+ git commit -m 'NEWS: Release $(PACKAGE) $(VERSION)' -- NEWS; \
+ git tag '$(PACKAGE)/$(VERSION)' HEAD; \
+ git push --tags origin master:master
+ md5sum $(DIST_ARCHIVES) >MD5SUMS
+ sha256sum $(DIST_ARCHIVES) >SHA256SUMS
+ ssh files@files.pehjota.net mkdir -p files/pub/$(PACKAGE)
+ rsync -az --progress --stats $(DIST_ARCHIVES) MD5SUMS SHA256SUMS \
+ files@files.pehjota.net:files/pub/$(PACKAGE)/$(VERSION)/
+
+include $(top_srcdir)/src/local.mk