summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2013-10-29 23:54:49 (EDT)
committer P. J. McDermott <pjm@nac.net>2013-10-29 23:54:49 (EDT)
commit218ea1df1a388ec4ab72dbf2871a70ef974014ce (patch)
treeb89faf04c917fa20b6b434384d6e09a503d0b33e
parentf564fa1aec5fbc57e92b39ab88649e29fbb309b6 (diff)
downloadweasyprint-218ea1df1a388ec4ab72dbf2871a70ef974014ce.zip
weasyprint-218ea1df1a388ec4ab72dbf2871a70ef974014ce.tar.gz
weasyprint-218ea1df1a388ec4ab72dbf2871a70ef974014ce.tar.bz2
debian/rules: Fix unpack-orig-source.
Ignore .git/ and fix "debian/" test.
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 187f72e..89f4d47 100755
--- a/debian/rules
+++ b/debian/rules
@@ -43,6 +43,7 @@ unpack-orig-source: get-orig-source
# Remove currently unpacked source.
for f in * .[!.] .??*; do \
if [ -e $${f} ] && [ $${f} != debian ] && \
+ [ $${f} != .git ] && \
[ $${f} != .gitignore ]; then \
rm -Rf $${f}; \
fi; \
@@ -57,7 +58,8 @@ unpack-orig-source: get-orig-source
# into the top-level directory.
set -e; \
for f in */ .[!.]/ .??*/; do \
- if [ -d $${f} ] && [ $${f} != debian ]; then \
+ if [ -d $${f} ] && [ $${f} != debian/ ] && [ $${f} != .git/ ]; \
+ then \
for ff in $${f}/* $${f}/.[!.] $${f}/.??*; do \
if [ -e $${ff} ]; then \
mv $${ff} .; \