summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index c314226..70ba43e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -31,6 +31,7 @@ unpack-orig-source: get-orig-source
# Remove currently unpacked source.
for f in * .[!.] .??*; do \
if [ -e $${f} ] && [ $${f} != debian ] && \
+ [ $${f} != .git ] && \
[ $${f} != .gitignore ]; then \
rm -Rf $${f}; \
fi; \
@@ -45,7 +46,8 @@ unpack-orig-source: get-orig-source
# into the top-level directory.
set -e; \
for f in */ .[!.]/ .??*/; do \
- if [ -d $${f} ] && [ $${f} != debian ]; then \
+ if [ -d $${f} ] && [ $${f} != debian/ ] && [ $${f} != .git/ ]; \
+ then \
for ff in $${f}/* $${f}/.[!.] $${f}/.??*; do \
if [ -e $${ff} ]; then \
mv $${ff} .; \