summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2013-10-29 22:48:11 (EDT)
committer P. J. McDermott <pjm@nac.net>2013-10-29 22:48:11 (EDT)
commitdc67e9c32de364b75942ce0f0dbb64b9d3f59afe (patch)
tree239e2bea09f65361dd21a554de9f3193c54a468d
parent81b9e820fc6d6cd25996c7a053e518d01216a622 (diff)
downloadpyphen-dc67e9c32de364b75942ce0f0dbb64b9d3f59afe.zip
pyphen-dc67e9c32de364b75942ce0f0dbb64b9d3f59afe.tar.gz
pyphen-dc67e9c32de364b75942ce0f0dbb64b9d3f59afe.tar.bz2
debian/rules: Fix unpack-orig-source.HEADmaster
Ignore .git/ and fix "debian/" test.
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index c314226..70ba43e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -31,6 +31,7 @@ unpack-orig-source: get-orig-source
# Remove currently unpacked source.
for f in * .[!.] .??*; do \
if [ -e $${f} ] && [ $${f} != debian ] && \
+ [ $${f} != .git ] && \
[ $${f} != .gitignore ]; then \
rm -Rf $${f}; \
fi; \
@@ -45,7 +46,8 @@ unpack-orig-source: get-orig-source
# into the top-level directory.
set -e; \
for f in */ .[!.]/ .??*/; do \
- if [ -d $${f} ] && [ $${f} != debian ]; then \
+ if [ -d $${f} ] && [ $${f} != debian/ ] && [ $${f} != .git/ ]; \
+ then \
for ff in $${f}/* $${f}/.[!.] $${f}/.??*; do \
if [ -e $${ff} ]; then \
mv $${ff} .; \