summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2023-10-01 13:03:30 (EDT)
committer P. J. McDermott <pj@pehjota.net>2023-10-01 15:22:44 (EDT)
commit91a8b35bb3bbb90cfe64afa241cc0a63b14e0fc7 (patch)
treea9e96fd276abc9300d5e8c58c4988c1079a9917f
parent1369c3fcb52c7e6500bf52ecfddf113747f05047 (diff)
downloadgatt-python-debian/latest.zip
gatt-python-debian/latest.tar.gz
gatt-python-debian/latest.tar.bz2
Add Debian packagingdebian/latest
-rw-r--r--.gitignore2
-rw-r--r--debian/.gitignore7
-rw-r--r--debian/changelog5
-rw-r--r--debian/clean1
-rw-r--r--debian/control29
-rw-r--r--debian/copyright30
-rw-r--r--debian/gattctl.143
-rw-r--r--debian/gbp.conf4
-rw-r--r--debian/patches/egg-info.patch11
-rw-r--r--debian/patches/series1
-rw-r--r--debian/python3-gatt.manpages1
-rwxr-xr-xdebian/rules6
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch3
-rw-r--r--gatt.egg-info/SOURCES.txt1
15 files changed, 145 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..a5fbc29
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+.pc/
+.pybuild/
diff --git a/debian/.gitignore b/debian/.gitignore
new file mode 100644
index 0000000..9adce86
--- /dev/null
+++ b/debian/.gitignore
@@ -0,0 +1,7 @@
+/.debhelper/
+/python3-gatt.postinst.debhelper
+/python3-gatt.prerm.debhelper
+/python3-gatt.substvars
+/python3-gatt/
+/debhelper-build-stamp
+/files
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..38c026e
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+gatt-python (0.2.7-1) UNRELEASED; urgency=medium
+
+ * Initial release. (Closes: #XXXXXX)
+
+ -- "P. J. McDermott" <pj@pehjota.net> Sun, 01 Oct 2023 09:32:50 -0400
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..9e8362f
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+.pybuild/
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..893880e
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,29 @@
+Source: gatt-python
+Maintainer: "P. J. McDermott" <pj@pehjota.net>
+Section: python
+Priority: optional
+Build-Depends: debhelper-compat (= 13), dh-python, python3-all, python3-setuptools
+Standards-Version: 4.6.2
+Homepage: https://github.com/getsenic/gatt-python
+#Vcs-Browser:
+#Vcs-Git:
+Rules-Requires-Root: no
+#X-Python3-Version: >= 3.4
+
+Package: python3-gatt
+Architecture: all
+Section: python
+Priority: optional
+Depends: ${misc:Depends}, ${python3:Depends}, bluez
+Description: Bluetooth GATT SDK for Python
+ The Bluetooth GATT SDK for Python helps you implement and communicate with any
+ Bluetooth Low Energy device that has a GATT profile. As of now it supports:
+ .
+ * Discovering nearby Bluetooth Low Energy devices
+ * Connecting and disconnecting devices
+ * Implementing your custom GATT profile
+ * Accessing all GATT services
+ * Accessing all GATT characteristics
+ * Reading characteristic values
+ * Writing characteristic values
+ * Subscribing for characteristic value change notifications
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..c07189b
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,30 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: gatt-python
+Source: https://pypi.org/project/gatt/
+
+Files: *
+Copyright: 2017 Senic GmbH
+License: Expat
+
+Files: debian/*
+Copyright: 2023 P. J. McDermott
+License: Expat
+
+License: Expat
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice shall be included in all
+ copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ SOFTWARE.
diff --git a/debian/gattctl.1 b/debian/gattctl.1
new file mode 100644
index 0000000..d7a3e68
--- /dev/null
+++ b/debian/gattctl.1
@@ -0,0 +1,43 @@
+.TH GATTCTL "1" "2023-10-01" "Bluetooth GATT SDK for Python 0.2.7" "User Commands"
+
+.SH NAME
+gattctl \- GATT SDK Demo
+
+.SH SYNOPSIS
+\fBgattctl\fP [\fB\-\-adapter ADAPTER\fP]
+(\fB\-\-power\-on\fP | \fB\-\-power\-off\fP | \fB\-\-powered\fP |
+\fB\-\-discover\fP | \fB\-\-connect\fP address | \fB\-\-auto\fP address |
+\fB\-\-disconnect\fP address)
+
+.SH OPTIONS
+.TP
+\fB\-h\fP, \fB\-\-help\fP
+Show a help message and exit
+.TP
+\fB\-\-adapter\fP ADAPTER
+Name of Bluetooth adapter, defaults to "hci0"
+.TP
+\fB\-\-power\-on\fP
+Powers the adapter on
+.TP
+\fB\-\-power\-off\fP
+Powers the adapter off
+.TP
+\fB\-\-powered\fP
+Print the adapter's power state
+.TP
+\fB\-\-discover\fP
+Lists all nearby GATT devices
+.TP
+\fB\-\-connect\fP address
+Connect to a GATT device with a given MAC address
+.TP
+\fB\-\-auto\fP address
+Connect and automatically reconnect to a GATT device with a given MAC address
+.TP
+\fB\-\-disconnect\fP address
+Disconnect a GATT device with a given MAC address
+
+.SH AUTHOR
+This manual page was written by P. J. McDermott <pj@pehjota.net> for the Debian
+system (but may be used by others).
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..ecc856f
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,4 @@
+[DEFAULT]
+pristine-tar = True
+debian-branch = debian/latest
+upstream-branch = upstream/latest
diff --git a/debian/patches/egg-info.patch b/debian/patches/egg-info.patch
new file mode 100644
index 0000000..eea96df
--- /dev/null
+++ b/debian/patches/egg-info.patch
@@ -0,0 +1,11 @@
+Author: "P. J. McDermott" <pj@pehjota.net>
+Description: Update egg info
+
+--- a/gatt.egg-info/SOURCES.txt
++++ b/gatt.egg-info/SOURCES.txt
+@@ -1,4 +1,5 @@
+ gattctl.py
++setup.cfg
+ setup.py
+ gatt/__init__.py
+ gatt/errors.py
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..61e93db
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+egg-info.patch
diff --git a/debian/python3-gatt.manpages b/debian/python3-gatt.manpages
new file mode 100644
index 0000000..651c4f9
--- /dev/null
+++ b/debian/python3-gatt.manpages
@@ -0,0 +1 @@
+debian/gattctl.1
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..eb3534f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,6 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=gatt
+
+%:
+ dh $@ --with=python3 --buildsystem=pybuild
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..4eb72da
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,3 @@
+version=4
+opts=uversionmangle=s/(rc|a|b|c)/~$1/ \
+https://pypi.debian.net/gatt/gatt-(.+)\.(?:zip|tgz|tbz|txz|(?:tar\.(?:gz|bz2|xz))) \ No newline at end of file
diff --git a/gatt.egg-info/SOURCES.txt b/gatt.egg-info/SOURCES.txt
index 676cb2f..6e72dd1 100644
--- a/gatt.egg-info/SOURCES.txt
+++ b/gatt.egg-info/SOURCES.txt
@@ -1,4 +1,5 @@
gattctl.py
+setup.cfg
setup.py
gatt/__init__.py
gatt/errors.py