summaryrefslogtreecommitdiffstats
path: root/man
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2012-07-02 22:08:08 (EDT)
committer P. J. McDermott <pjm@nac.net>2012-07-02 22:36:42 (EDT)
commit7a2a19e2eb43c48cb4cd6bcd8b2a55436cec5ca9 (patch)
tree8d6b65779596ef1184d47740b994a1716881673d /man
downloaddeb-7a2a19e2eb43c48cb4cd6bcd8b2a55436cec5ca9.zip
deb-7a2a19e2eb43c48cb4cd6bcd8b2a55436cec5ca9.tar.gz
deb-7a2a19e2eb43c48cb4cd6bcd8b2a55436cec5ca9.tar.bz2
Initial commit.
The build system is based on that of opkhelper 1.0.0.
Diffstat (limited to 'man')
-rw-r--r--man/Makefile.in73
1 files changed, 73 insertions, 0 deletions
diff --git a/man/Makefile.in b/man/Makefile.in
new file mode 100644
index 0000000..0c12d5d
--- /dev/null
+++ b/man/Makefile.in
@@ -0,0 +1,73 @@
+# DEB - Download, Edit, Build!
+# Makefile.in
+# Input Makefile for configure.
+#
+# Copyright (C) 2012 Patrick "P. J." McDermott
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+SHELL = @shell@
+INSTALL = @install@
+MAKE = @make@
+
+SRCDIR = @srcdir@
+PREFIX = @prefix@
+MANDIR = @mandir@
+
+.SUFFIXES:
+.SUFFIXES: .in
+
+SRCS =
+OBJS = $(SRCS:.in=)
+
+PACKAGE = @package@
+VERSION = @version@
+
+distdir = ../$(PACKAGE)-$(VERSION)/man
+distfiles = Makefile.in $(SRCS)
+
+.PHONY: all
+all: $(OBJS)
+
+$(OBJS):
+ @printf ' CP man/%s\n' '$@'
+ @sed -f ../sedscript $(SRCDIR)/man/$@.in > $@
+
+.PHONY: clean
+clean:
+ @for obj in $(OBJS); do \
+ printf ' RM man/%s\n' "$${obj}"; \
+ rm -f $${obj}; \
+ done
+
+.PHONY: install
+install: all
+ @for obj in $(OBJS); do \
+ printf ' INSTALL man/%s\n' "$${obj}"; \
+ section=$$(echo "$${obj}" | sed 's/^.*[.]\([0-9]\)$$/\1/'); \
+ $(INSTALL) -D $${obj} "$(DESTDIR)/$(MANDIR)/man$${section}/$${obj}"; \
+ done
+
+.PHONY: uninstall
+uninstall:
+ @for obj in $(OBJS); do \
+ printf ' RM %s\n' "$${obj}"; \
+ section=$$(echo "$${obj}" | sed 's/^.*[.]\([0-9]\)$$/\1/'); \
+ rm -f "$(DESTDIR)/$(MANDIR)/man$${section}/$${obj}"; \
+ done
+
+.PHONY: distdir
+distdir:
+ @[ -d '$(distdir)' ] || mkdir '$(distdir)'
+ @cp -pR $(distfiles) $(distdir)