summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2013-10-29 21:47:23 (EDT)
committer P. J. McDermott <pjm@nac.net>2013-10-29 21:47:23 (EDT)
commita99e623d0f612d5879ff48f982a393af712e084c (patch)
treec6208f45d12edaa792c026f2b32737540a20e627
parent5ae82c412558f4d94855a8fe637a02f300e197d2 (diff)
downloadcairocffi-master.zip
cairocffi-master.tar.gz
cairocffi-master.tar.bz2
debian/rules: Fix unpack-orig-source.HEADmaster
Ignore .git/ and fix "debian/" test.
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index cf33004..8f147e9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,6 +38,7 @@ unpack-orig-source: get-orig-source
# Remove currently unpacked source.
for f in * .[!.] .??*; do \
if [ -e $${f} ] && [ $${f} != debian ] && \
+ [ $${f} != .git ] && \
[ $${f} != .gitignore ]; then \
rm -Rf $${f}; \
fi; \
@@ -52,7 +53,8 @@ unpack-orig-source: get-orig-source
# into the top-level directory.
set -e; \
for f in */ .[!.]/ .??*/; do \
- if [ -d $${f} ] && [ $${f} != debian ]; then \
+ if [ -d $${f} ] && [ $${f} != debian/ ] && [ $${f} != .git/ ]; \
+ then \
for ff in $${f}/* $${f}/.[!.] $${f}/.??*; do \
if [ -e $${ff} ]; then \
mv $${ff} .; \