summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 24 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index cb1f0ce..5b527de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
# Process this file with autoconf to produce a configure script.
#
-# Copyright (C) 2013, 2017, 2019, 2021 P. J. McDermott
+# Copyright (C) 2013, 2017, 2019, 2021, 2022 P. J. McDermott
#
# This file is part of @
#
@@ -32,6 +32,12 @@ AM_CONDITIONAL([OUT_OF_TREE], [test x"${srcdir}" != x'.' ])
AM_CONDITIONAL([CROSS_COMPILING], [! test x"${build_alias}" = x"${host_alias}"])
+GETTEXT_PACKAGE="${PACKAGE}"
+AC_SUBST([GETTEXT_PACKAGE])
+AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], ["${GETTEXT_PACKAGE}"],
+ [Define the gettext package to be used.])
+AM_GNU_GETTEXT([external])
+
save_CFLAGS="${CFLAGS-}"
AC_PROG_CC()
AM_PROG_CC_C_O()
@@ -42,7 +48,7 @@ AC_CHECK_FUNCS(
[\
calloc difftime fprintf fputs free isspace localtime mktime \
printf realloc setvbuf sleep strerror strlen strftime strptime \
- time timegm
+ time
],
[],
[funcs_missing=true])
@@ -56,17 +62,26 @@ if ${funcs_missing}; then
AC_MSG_ERROR([required functions are missing])
fi
+AC_PROG_LN_S()
+AC_ARG_ENABLE([symlink],
+ [AS_HELP_STRING([--disable-symlink],
+ [don't install \`@' symbolic link])],
+ [case "${enableval}" in yes|no) symlink=${enableval};;
+ *) AC_MSG_ERROR(
+ [bad value ${enableval} for symlink option]);;
+ esac],
+ [symlink=yes]
+)
+AM_CONDITIONAL([ENABLE_SYMLINK], [test x"${symlink}" = x'yes'])
+
AC_ARG_ENABLE([tests],
- [AS_HELP_STRING([--enable-tests],
- [include test suite support in executable])],
+ [AS_HELP_STRING([--disable-tests],
+ [exclude test suite support from executable])],
[case "${enableval}" in yes|no) tests=${enableval};;
*) AC_MSG_ERROR(
[bad value ${enableval} for tests option]);;
esac],
- [
- tests=no
- test -d "${srcdir}/.git" && tests=yes
- ]
+ [tests=yes]
)
if test x"${tests}" = x'yes'; then
AC_DEFINE([ENABLE_TESTS], [1],
@@ -142,6 +157,6 @@ for flag in -Os -fno-unwind-tables -fno-asynchronous-unwind-tables \
AX_CHECK_COMPILE_FLAG([${flag}], [AX_APPEND_FLAG([${flag}])])
done
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile po/Makefile.in])
AC_CONFIG_HEADERS([config.h])
AC_OUTPUT()