summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2023-10-06 08:09:54 (EDT)
committer P. J. McDermott <pj@pehjota.net>2023-10-06 09:05:28 (EDT)
commit84a56a1f46e1c09775f533a5f335ddebdd74c92f (patch)
treed2cf90e22b7498abe98fdbffa66b595066e8b80c /configure.ac
parent89b67a868e2023d41a29609c2fa186174e634952 (diff)
downloadatsign-84a56a1f46e1c09775f533a5f335ddebdd74c92f.zip
atsign-84a56a1f46e1c09775f533a5f335ddebdd74c92f.tar.gz
atsign-84a56a1f46e1c09775f533a5f335ddebdd74c92f.tar.bz2
build: gettextize
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6578718..a42b73e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,12 @@ AM_CONDITIONAL([OUT_OF_TREE], [test x"${srcdir}" != x'.' ])
AM_CONDITIONAL([CROSS_COMPILING], [! test x"${build_alias}" = x"${host_alias}"])
+GETTEXT_PACKAGE="${PACKAGE}"
+AC_SUBST([GETTEXT_PACKAGE])
+AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], ["${GETTEXT_PACKAGE}"],
+ [Define the gettext package to be used.])
+AM_GNU_GETTEXT([external])
+
save_CFLAGS="${CFLAGS-}"
AC_PROG_CC()
AM_PROG_CC_C_O()
@@ -155,6 +161,6 @@ for flag in -Os -fno-unwind-tables -fno-asynchronous-unwind-tables \
AX_CHECK_COMPILE_FLAG([${flag}], [AX_APPEND_FLAG([${flag}])])
done
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile po/Makefile.in])
AC_CONFIG_HEADERS([config.h])
AC_OUTPUT()