summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2023-10-05 11:14:46 (EDT)
committer P. J. McDermott <pj@pehjota.net>2023-10-05 11:14:46 (EDT)
commit28636d7a3521faf76aa9c26f25538dc4ae84aa7c (patch)
treed87a29e01835df540d277bfc574f4bbdc10c4337 /Makefile.am
parent86a7f466b1545ee0d6f634414bc7b18dbdb1d36f (diff)
downloadatsign-28636d7a3521faf76aa9c26f25538dc4ae84aa7c.zip
atsign-28636d7a3521faf76aa9c26f25538dc4ae84aa7c.tar.gz
atsign-28636d7a3521faf76aa9c26f25538dc4ae84aa7c.tar.bz2
build: Automake broke the test suite summary
Because of this in our Makefile.am: PACKAGE_VERSION_GIT = $$(git describe --tags --dirty | sed 's|^[^/-]*[/-]||') PACKAGE_STRING = $(PACKAGE_NAME) $(PACKAGE_VERSION_GIT) and this in Automake lib/am/check.am since version 1.16.3: AM_TESTSUITE_SUMMARY_HEADER = ' for $(PACKAGE_STRING)' the test suite summary header came out like this: /bin/bash: -c: line 64: syntax error near unexpected token `(' /bin/bash: -c: line 64: `echo "${col}Testsuite summary"' for @ 1.0.0$(printf ' (%s)' "$({ git describe --tags --dirty 2>/dev/null || printf '%s-g%s' "$(git rev-list --count HEAD)" "$(git describe --tags --dirty --always)"; } | sed 's|^.*/||')")'"${std}"; \' but is now fixed to look like this: ============================================================================ Testsuite summary for @ 1.0.0 (93-g86a7f46-dirty) ============================================================================
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c6d8e2b..778b251 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,6 +40,10 @@ endif
# * Our release target
PACKAGE_STRING = $(PACKAGE_NAME) $(PACKAGE_VERSION)$(PACKAGE_VERSION_GIT)
+# Automake lib/am/check.am since version 1.16.3 defines this with single quotes,
+# which breaks PACKAGE_VERSION_GIT above.
+AM_TESTSUITE_SUMMARY_HEADER = " for $(PACKAGE_STRING)"
+
bin_PROGRAMS = atsign
atsign_SOURCES =