summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2021-08-28 14:28:55 (EDT)
committer P. J. McDermott <pj@pehjota.net>2021-08-28 14:28:55 (EDT)
commit21e7e051b8c14d764bb283da59d8c04fb336ed77 (patch)
tree3718341d3abeb0e472ace1c834a8759b4bd2c67c /Makefile.am
downloadatsign-21e7e051b8c14d764bb283da59d8c04fb336ed77.zip
atsign-21e7e051b8c14d764bb283da59d8c04fb336ed77.tar.gz
atsign-21e7e051b8c14d764bb283da59d8c04fb336ed77.tar.bz2
Initial commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am114
1 files changed, 114 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..8cc00e8
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,114 @@
+# Process this file with automake to produce an input makefile.
+#
+# Copyright (C) 2013, 2014, 2017, 2018, 2021 P. J. McDermott
+#
+# This file is part of @
+#
+# @ is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# @ is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with @. If not, see <http://www.gnu.org/licenses/>.
+
+KEY = 'B47A 6674 80CD A1F8 361B 31EE FCDF 9F3F B5D7 3216'
+
+if IN_GIT
+PACKAGE_VERSION_GIT = $$(printf ' (%s)' \
+ "$$({ git describe --tags --dirty 2>/dev/null || \
+ printf '%s-g%s' \
+ "$$(git rev-list --count HEAD)" \
+ "$$(git describe --tags --dirty --always)"; \
+ } | sed 's|^.*/||')")
+else
+PACKAGE_VERSION_GIT =
+endif
+
+# PACKAGE_STRING is used in the test suite output and log.
+# PACKAGE_VERSION can't be overridden. Automake ignores it in the IN_GIT
+# conditional (and throws a warning), and setting it to $(PACKAGE_VERSION_GIT)
+# outside the conditional causes PACKAGE_VERSION_GIT to reference itself.
+# VERSION is not set here because it is used by:
+# * Automake's distdir macro
+# * Automake's distdir target (which checks for $(VERSION) in NEWS)
+# * Our release target
+PACKAGE_STRING = $(PACKAGE_NAME) $(PACKAGE_VERSION)$(PACKAGE_VERSION_GIT)
+
+bin_PROGRAMS = @
+
+@_SOURCES =
+@_CFLAGS = \
+ $(WARN_CFLAGS) \
+ $(ASAN_CFLAGS)
+@_CPPFLAGS = \
+ $(SDL_CFLAGS) \
+ $(SDL_TTF_CFLAGS) \
+ -DABS_BUILDDIR=\"$(abs_builddir)\" \
+ -DFONTSDIR=\"$(fontsdir)\"
+@_LDADD = \
+ $(ASAN_CFLAGS) \
+ $(SDL_LIBS) \
+ $(SDL_TTF_LIBS)
+@_LINK = $(LINK) version.c
+EXTRA_@_DEPENDENCIES = version.c $(DATA)
+CLEANFILES = version.c
+CONFIG_CLEAN_FILES =
+EXTRA_DIST = autogen.sh
+
+V_REDIR = $(V_REDIR_$(V))
+V_REDIR_ = $(V_REDIR_$(AM_DEFAULT_VERBOSITY))
+V_REDIR_0 = 1>/dev/null 2>&1
+V_REDIR_1 =
+
+version.c: $(@_OBJECTS) $(@_DEPENDENCIES)
+ $(AM_V_GEN)printf 'const char *PACKAGE_VERSION_GIT = "%s";\n' \
+ "$(PACKAGE_VERSION_GIT)" >version.c
+
+really-clean: distclean
+ rm -Rf $(srcdir)/aclocal.m4 $(srcdir)/autom4te.cache/ \
+ $(srcdir)/configure \
+ $(srcdir)/config.h.in \
+ $(srcdir)/build-aux/ $(srcdir)/INSTALL $(srcdir)/Makefile.in \
+ $(srcdir)/ChangeLog
+
+dist-hook:
+ set -e; \
+ if [ -d '$(srcdir)/.git' ]; then \
+ printf 'Generated file. Do not edit.\n\n' \
+ >'$(distdir)/ChangeLog~'; \
+ GIT_DIR='$(srcdir)/.git' git log --stat --color=never \
+ >>'$(distdir)/ChangeLog~'; \
+ mv '$(distdir)/ChangeLog~' '$(distdir)/ChangeLog'; \
+ fi
+
+release:
+ sed "s/^Released: ????-??-??\$$/Released: $$(date '+%Y-%m-%d')/" \
+ '$(srcdir)/NEWS' >'$(srcdir)/NEWS~'
+ mv '$(srcdir)/NEWS~' '$(srcdir)/NEWS'
+ $(MAKE) distcheck
+ set -e; \
+ export GIT_DIR='$(srcdir)/.git'; \
+ export GIT_WORK_TREE='$(srcdir)'; \
+ git commit -m 'NEWS: Release $(PACKAGE) $(VERSION)' -- NEWS; \
+ git tag '$(PACKAGE)/$(VERSION)' HEAD; \
+ git push --tags origin master:master
+ md5sum $(DIST_ARCHIVES) >MD5SUMS
+ sha256sum $(DIST_ARCHIVES) >SHA256SUMS
+ set -e; \
+ sigs=''; \
+ for f in $(DIST_ARCHIVES); do \
+ gpg --local-user $(KEY) --armor --detach-sign $${f}; \
+ sigs="$${sigs} $${f}.asc"; \
+ done; \
+ ssh files@files.pehjota.net mkdir -p files/pub/$(PACKAGE); \
+ rsync -az --progress --stats $(DIST_ARCHIVES) $${sigs} \
+ MD5SUMS SHA256SUMS \
+ files@files.pehjota.net:files/pub/$(PACKAGE)/$(VERSION)/
+
+include $(top_srcdir)/src/local.mk