summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2023-10-16 11:05:37 (EDT)
committer P. J. McDermott <pj@pehjota.net>2023-10-16 11:05:37 (EDT)
commit0c8a3333bf62457cb3bef676205ab7158af14ad6 (patch)
tree4c2a1c18b98d82f5309523209c3861e937f87d04 /Makefile.am
parent605fc281c1fd80b63b6bc608e5882b1abaec0035 (diff)
downloadatsign-master.zip
atsign-master.tar.gz
atsign-master.tar.bz2
build: cd && ln as advised by Autoconf manualHEADmaster
https://www.gnu.org/savannah-checkouts/gnu/autoconf/manual/autoconf-2.71/html_node/Particular-Programs.html#index-AC_005fPROG_005fLN_005fS-1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 883846c..b53c109 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -86,18 +86,20 @@ really-clean: distclean
if ENABLE_SYMLINK
install-exec-hook:
@set -e; \
+ dir="$(DESTDIR)$(bindir)"; \
dst="$$(printf 'atsign' | \
sed '$(transform); s/$$/$(EXEEXT)/')"; \
- src='$(DESTDIR)$(bindir)/@$(EXEEXT)'; \
- echo " $(LN_S) '$${dst}' '$${src}'"; \
- $(LN_S) "$${dst}" "$${src}"
+ src='@$(EXEEXT)'; \
+ echo " (cd '$${dir}' && $(LN_S) '$${dst}' '$${src}')"; \
+ (cd "$${dir}" && $(LN_S) "$${dst}" "$${src}")
install-data-hook:
@set -e; \
+ dir="$(DESTDIR)$(man1dir)"; \
dst="$$(printf 'atsign' | \
sed '$(transform); s/$$/$(EXEEXT)/').1"; \
- src='$(DESTDIR)$(man1dir)/@$(EXEEXT).1'; \
- echo " $(LN_S) '$${dst}' '$${src}'"; \
- $(LN_S) "$${dst}" "$${src}"
+ src='@$(EXEEXT).1'; \
+ echo " (cd '$${dir}' && $(LN_S) '$${dst}' '$${src}')"; \
+ (cd "$${dir}" && $(LN_S) "$${dst}" "$${src}")
uninstall-hook:
echo " rm -f '$(DESTDIR)$(bindir)/@$(EXEEXT)'"
rm -f "$(DESTDIR)$(bindir)/@$(EXEEXT)"