summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2023-10-01 10:52:07 (EDT)
committer P. J. McDermott <pj@pehjota.net>2023-10-01 10:52:07 (EDT)
commit1369c3fcb52c7e6500bf52ecfddf113747f05047 (patch)
tree2862ad27d6028c1ebcc47b05396c956157059960 /setup.py
downloadgatt-python-880f2bf18e3d3a63bec2b878acab492ad730b086.zip
gatt-python-880f2bf18e3d3a63bec2b878acab492ad730b086.tar.gz
gatt-python-880f2bf18e3d3a63bec2b878acab492ad730b086.tar.bz2
New upstream version 0.2.7upstream/0.2.7upstream/latest
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 18 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..574327f
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,18 @@
+from setuptools import setup
+
+setup(
+ name='gatt',
+ packages=['gatt'],
+ version='0.2.7',
+ description='Bluetooth GATT SDK for Python',
+ keywords='gatt',
+ url='https://github.com/getsenic/gatt-python',
+ download_url='https://github.com/getsenic/gatt-python/archive/0.2.7.tar.gz',
+ author='Senic GmbH',
+ author_email='developers@senic.com',
+ license='MIT',
+ py_modules=['gattctl'],
+ entry_points={
+ 'console_scripts': ['gattctl = gattctl:main']
+ }
+)