summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am72
1 files changed, 58 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 0048520..b53c109 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
# Process this file with automake to produce an input makefile.
#
-# Copyright (C) 2013, 2014, 2017, 2018, 2021 P. J. McDermott
+# Copyright (C) 2013, 2014, 2017, 2018, 2021, 2022 P. J. McDermott
#
# This file is part of @
#
@@ -40,33 +40,39 @@ endif
# * Our release target
PACKAGE_STRING = $(PACKAGE_NAME) $(PACKAGE_VERSION)$(PACKAGE_VERSION_GIT)
-bin_PROGRAMS = @
+# Automake lib/am/check.am since version 1.16.3 defines this with single quotes,
+# which breaks PACKAGE_VERSION_GIT above.
+AM_TESTSUITE_SUMMARY_HEADER = " for $(PACKAGE_STRING)"
-@_SOURCES =
-@_CFLAGS = \
+bin_PROGRAMS = atsign
+
+atsign_SOURCES =
+atsign_CFLAGS = \
$(WARN_CFLAGS) \
$(ASAN_CFLAGS)
-@_CPPFLAGS = \
+atsign_CPPFLAGS = \
$(SDL_CFLAGS) \
$(SDL_TTF_CFLAGS) \
-DABS_BUILDDIR=\"$(abs_builddir)\" \
- -DFONTSDIR=\"$(fontsdir)\"
-@_LDADD = \
+ -DLOCALEDIR=\"$(localedir)\"
+atsign_LDADD = \
$(ASAN_CFLAGS) \
$(SDL_LIBS) \
$(SDL_TTF_LIBS)
-@_LINK = $(LINK) version.c
-EXTRA_@_DEPENDENCIES = version.c
+atsign_LINK = $(LINK) version.c
+EXTRA_atsign_DEPENDENCIES = version.c
CLEANFILES = version.c
CONFIG_CLEAN_FILES =
-EXTRA_DIST = autogen.sh FORMATS
+EXTRA_DIST = build-aux/config.rpath autogen.sh
V_REDIR = $(V_REDIR_$(V))
V_REDIR_ = $(V_REDIR_$(AM_DEFAULT_VERBOSITY))
V_REDIR_0 = 1>/dev/null 2>&1
V_REDIR_1 =
-version.c: $(@_OBJECTS) $(@_DEPENDENCIES)
+SUFFIXES =
+
+version.c: $(atsign_OBJECTS) $(atsign_DEPENDENCIES)
$(AM_V_GEN)printf 'const char *PACKAGE_VERSION_GIT = "%s";\n' \
"$(PACKAGE_VERSION_GIT)" >version.c
@@ -77,7 +83,37 @@ really-clean: distclean
$(srcdir)/build-aux/ $(srcdir)/INSTALL $(srcdir)/Makefile.in \
$(srcdir)/ChangeLog
+if ENABLE_SYMLINK
+install-exec-hook:
+ @set -e; \
+ dir="$(DESTDIR)$(bindir)"; \
+ dst="$$(printf 'atsign' | \
+ sed '$(transform); s/$$/$(EXEEXT)/')"; \
+ src='@$(EXEEXT)'; \
+ echo " (cd '$${dir}' && $(LN_S) '$${dst}' '$${src}')"; \
+ (cd "$${dir}" && $(LN_S) "$${dst}" "$${src}")
+install-data-hook:
+ @set -e; \
+ dir="$(DESTDIR)$(man1dir)"; \
+ dst="$$(printf 'atsign' | \
+ sed '$(transform); s/$$/$(EXEEXT)/').1"; \
+ src='@$(EXEEXT).1'; \
+ echo " (cd '$${dir}' && $(LN_S) '$${dst}' '$${src}')"; \
+ (cd "$${dir}" && $(LN_S) "$${dst}" "$${src}")
+uninstall-hook:
+ echo " rm -f '$(DESTDIR)$(bindir)/@$(EXEEXT)'"
+ rm -f "$(DESTDIR)$(bindir)/@$(EXEEXT)"
+endif
+
+if ENABLE_TESTS
+if CROSS_COMPILING
dist-hook:
+else !CROSS_COMPILING
+dist-hook: atsign$(EXEEXT)
+endif !CROSS_COMPILING
+else !ENABLE_TESTS
+dist-hook:
+endif !ENABLE_TESTS
if IN_GIT
printf 'Generated file. Do not edit.\n\n' 1>'$(distdir)/ChangeLog~'
GIT_DIR='$(srcdir)/.git' git log --stat --color=never \
@@ -86,16 +122,21 @@ if IN_GIT
endif
if ENABLE_TESTS
if CROSS_COMPILING
- if ! [ -f 'FORMATS' ]; then \
+ if [ -f 'FORMATS' ]; then \
+ cp -p 'FORMATS' '$(distdir)/FORMATS'; \
+ else \
printf 'Error: "FORMATS" file cannot be generated when %s' \
'cross compiling' 1>&2; \
exit 1; \
fi
else !CROSS_COMPILING
- $(srcdir)/@ -d '1969-12-31 19:00:01' -F 1>FORMATS
+ $(builddir)/atsign$(EXEEXT) -d '1969-12-31 19:00:01' -F \
+ 1>'$(distdir)/FORMATS'
endif !CROSS_COMPILING
else !ENABLE_TESTS
- if ! [ -f 'FORMATS' ]; then \
+ if [ -f 'FORMATS' ]; then \
+ cp -p 'FORMATS' '$(distdir)/FORMATS'; \
+ else \
printf 'Error: "FORMATS" file cannot be generated without %s' \
'test suite support' 1>&2; \
exit 1; \
@@ -127,4 +168,7 @@ release:
files@files.pehjota.net:files/pub/$(PACKAGE)/$(VERSION)/
include $(top_srcdir)/src/local.mk
+include $(top_srcdir)/man/local.mk
include $(top_srcdir)/tests/local.mk
+
+SUBDIRS = . po